منبع اصلی نوشتار زیر در این لینک قرار دارد

حل آسیب پذیری بسته Bash برای فدورا لینوکس

shellshock

با توجه به اخباری که چند روز پیش در مورد باگ مربوط به بسته ی Bash منتشر شد هم اکنون بسته ی بروز رسانی bash برای فدورا آماده و قابل بروزرسانی می باشد.

این باگ امنیتی CVE-2014-6271 و  CVE-2014-7169  نام دارد و به Shellshock معروف می باشد که برای اطلاعات بیشتر می توانید به اینجا مراجعه نمایید.

برای اینکه از وجود این آسیب پذیری بر روی سیستم خود مطلع شوید کافیست تا این دستور را اجرا نمایید :

env x='() { :;}; echo OOPS' bash -c :

اگر در خروجی دستور گفته شده واژه ی  OOPS را مشاهده کردید،سیستم شما این آسیب پذیری را دارد و باید سیستم و یا بسته ی bash را بروزرسانی نمایید.بسته ی بروز رسانی bash برای Fedora 19 , Fedora 20  و Fedora 21 در دسترس می باشد که هم اکنون می توانید از این بروزرسانی استفاده نمایید.

جهت بروزرسانی می توانید از ابزارهای مدیریت بسته ی گرافیکی مانند KPackageKit یا Yumex استفاده نمایید و یا اینکه با استفاده از این دستور yum سیستم خود را بروزرسانی نمایید :

#yum update

 

و یا اینکه جهت بروزرسانی بسته ی bash می توانید این دستور را اجرا نمایید :

#yum update bash

 



برچسب ها : , , , , , , , , , , , , , , ,

به سیاره لینوکس امتیاز دهید

به اين صفحه امتياز دهيد