منبع اصلی نوشتار زیر در این لینک قرار دارد

سیستم خود را در اولین فرصت به روز کنید!

Bash نرم‌افزاری که در اکثر سیستم‌های BSD،Linux Based و OS X به‌صورت پیش‌فرض استفاده می‌شود و کاربرد گسترده‌ای در توزیع‌های گنو/لینوکس دارد! اکثر کاربران سرور نیز از Bash استفاده می‌کنند! اگر در توزیع خود نیز دنبال نرم‌افزارهای وابسته به Bash باشید احتمالاً لیست این برنامه‌ها نسبتاً بلندبالا خواهند بود. این نرم‌افزار یک مفسر خط فرمان است.

حالا چه اتفاقی افتاده است؟ این نرم‌افزار چندین سال است که دارای یک باگ و حفره امنیتی می‌باشد که هیچ‌کس هم آن را خبر نداشته و بنابراین دست به آن‌هم نزده است خلاصه کلام اینکه همانند باگ قبلی در OpenSSL این مشکل هم برای امنیت کاربران سیستم‌عامل‌های بهره‌جو از Bash بسیار خطرناک است!

Current-Git-Branch-In-Bash-Prompt1به این باگ Shellshock یا Bash Bug می گویند وnist.gov درجه خطر آن را ۱۰ از ۱۰ اعلام کرده‌!!! برای اطلاعات بیشتر در مورد این باگ به این صفحه‌ی وبلاگ رسیم شرکت بیان مراجعه کنید.

چه کنم؟

سیستم خود را به‌روز کنید! شاید کلیشه‌ای باشد اما چاره‌ای جز این کار مگر وجود دارد؟ همچنین دستوراتی را که برای تشخیص آلودگی یا عدم آلودگی وجود دارند را اجرا کنید تا مطمئن شوید دیگر مشکلی وجود ندارد. این مطلب آقای آموزگار در سایت زومیت را هم مطالعه کنید!

منابع: +

ارسال نظر سریع



برچسب ها : , , ,

به سیاره لینوکس امتیاز دهید

به اين صفحه امتياز دهيد